New in ProShow Producer 4.1

ProShow Producer

ProShow Producer 4.1 was a substantial update that included hundreds of fixes and improvements based on user feedback.

Improved Preview in Slide Options

  • New! Improved preview performance makes working with complex slides faster.
  • New! New layer and caption control outlines
    • Improved outlines are easier to see
    • Grab any knob to change the size
    • New rotation icons in each corner let you easily rotate layers and captions
  • New! New keyframe markers and motion paths help you quickly see how a layer is moving in the preview.
    • Layers now show their keyframe markers in the preview, allowing you to see which keyframe is currently being displayed.
    • Improved motion paths include arrows to show which direction the layer is moving
    • Easily turn on motion paths by right-clicking in the preview
  • New! Added snap-to rotation when the SHIFT key is held during rotation. Layers will snap to 45 degree increments.
  • Caption previews now support the ‘Select caption with mouse click’ and ‘Show caption controls’ options (right click on the preview to adjust these settings).

Improvements for Adding Content to Shows

  • New! Double-click any photo in the File List to add it to your show.
  • New! Added ‘Add as One New Slide’ to right-click menu in the File List and to the Insert menu under main Slide menu. Adds the selected files as layers on a single new slide in the show.

Additional Output Options

  • New! Facebook Support
    • Create output for your Facebook page
    • Built-in support for uploading directly from ProShow
  • New! Vimeo Support
    • Create videos for the Vimeo sharing site
    • Upload HD video to Vimeo from within ProShow
  • New!Announce Shows on Twitter
    • Tweet an announcement about your show after uploading to Photodex, YouTube, Facebook or Vimeo
    • Fully integrated – just enter your login information
    • Automatic shortening of long URLs
  • New! Output video files in the Theora format, supported by most HTML 5 web browsers
  • Improved Photodex Uploading now provides a link to the show after uploading
  • Added option to pause video rendering
  • Added completion message to Web Show output to let you know when its complete
  • Enhanced menu theme list in output dialogs to remember the selected category and selection.
  • Added support for YouTube’s 1080p HD video uploading.

All New Help Documentation and Manual

  • New! Entirely new documentation written from scratch.
    • Based on user feedback, we scrapped the entire manual and help file and started over.
    • New documentation takes an instructional approach, rather than simply describing buttons and features.
    • Filled with examples of key features and concepts.
    • Organized by concept, rather than interface layout.
    • Reviewed, edited, and critiqued by real users.
  • New! Full manual available as a PDF from the Photodex website
    • Over 500 pages of all new documentation
    • PDF version available free, includes same content as found in the printed book.
  • New! Built-in help included with every copy of ProShow 4.1
    • Includes the same content found in the new manual
    • Provided in the industry standard Windows Help format, which allows searching and printing.

Improvements to Working in Slide Options

  • New! Enhanced timing control
    • New! Total time for slide is now displayed at the bottom of Slide Options
    • New! Click the total time indicator to change timing
      • Set slide time and transition times
      • See the new total time based on the changes you are making
      • See the difference between the new and old timing
    • New! Improved timing control in Slide Options > Slide Settings
      • Set transition times in addition to slide time
      • See the total time based on the changes
    • New! Added “Set Effect Time” to right click menus for caption Fly In/Out areas in Caption Motion
    • New! Added option to switch between minutes/seconds and just seconds for keyframe timelines. Option accessible by right-clicking on the keyframe timeline, or from within the Preferences.
  • New! Added button in upper right corner of Slide Options to allow direct access to any Slide Options screen.
  • New! Added keyboard shortcut CTRL+D for toggling size of Slide Options
  • New! Added keyboard shortcut for playing / stopping Slide Options preview areas (CTRL + Q)
  • New! Added “Copy End to Start” option to the copy menu in Effects tabs
  • Added reset option for background image fields to remove the background image.
  • Changed the “Motion Styles” feature to “Motion Speed” to increase clarity of function

Improvements to Slide Styles

  • New! Redesigned slide style list makes it easier to browse for a style
    • Enhanced the look of the Slide Styles list to make the layers and aspect ratio information more readable.
    • Added the recommended timing to each item in the list.
    • Improved layer # indicator in slide styles list to improve visibility and better indicate when it matches the slide
    • Added new Slide Styles list mode which shows only the style name, aspect ratio, and layer count, enabling more styles to appear in the list at once
  • New! New multi-category support lets you better organize your styles
    • Styles can now have multiple categories applied at once.
    • New categorization interface
      • Adjust categories for multiple styles at once
      • Change categories quickly without having to access each style individually
      • Add or remove categories at will
  • New! Improved style filtering options
    • Added bar above slide styles list to show the number of Slide Styles shown by the current filter settings. Can be clicked to show all.
    • Added option to filter slide styles by aspect ratio of current show. Select Match Show to display only styles that match the aspect ratio of the current show.
    • Expanded the layer filter to let you filter by a wider range of layer numbers.
    • Improved slide style filter for aspect ratio to provide more accurate results and better handle custom aspect ratios.
    • Enhanced the Slide Style filtering options to use drop-down menus instead of combo-boxes, allowing for more descriptive text to be displayed.
    • Category filter options now show the number of styles in each category.
  • New! Easily add slide styles
    • Double-click any PXS file in Windows Explorer to install it in ProShow.
    • When downloading PXS files from the web, choosing ‘Open’ (instead of ‘Save’) will automatically install into ProShow.
    • Import multiple styles at once from the Manage Styles window. Just select multiple PXS files when browsing for a file.
  • New! Quickly browse styles with ‘Next’ and ‘Previous’ buttons
  • Improved style storage, reducing the need to reinstall styles with each ProShow update
    • Slide styles are now stored in the Windows AppData/ProgramData folder
    • Multiple installations of ProShow on the same computer can now share one repository of styles
    • Easily backup styles by copying just the AppData/ProgramData folder
  • Greatly improved speed of using styles when you have a large number of styles installed
  • Added ability to access the Slide Style Manager from the main interface via Slide menu. Allows you to manage styles without going through Slide Options.
  • Enhanced Manage Styles dialog now appears larger, and displays a variety of information about the selected style.

Improved Layers List

  • New! Redesigned layers list makes it easier to work with layers in your slides.
    • Cleaner design provides improved readability
    • New icons for mask and adjustment layers make these specialty layers easier to see
    • Notes icon appears in the list for layers which contain notes
    • Improved display of hidden layers to make their state more obvious
  • Indentation shows the relationship between nested layers
    • Easily see which layers are affected by a mask or adjustment layer
    • Click and drag indentation lines for masks to change what layers are in the mask
  • Work faster and easier
    • Easily add layers by right clicking anywhere in the list
    • Quickly rename a layer by right clicking on it
    • Greatly improved performance of list when many layers exist in a slide

Improved Captions List

  • New! Redesigned Captions List makes it easier to work with captions on your slides.
  • Captions are now displayed in the font you’ve selected for that caption, making it easier to spot captions in the list.
  • Captions that start with a blank line now show their first line of actual text in the list, instead of just ‘…’
  • Caption list in Show Options now shows the global caption icon to indicate the captions appear on all slides.

Improved Slide List

  • Added ability to rename a slide from the slide list by right-clicking on the slide.
  • Added tooltip to Slide List that displays details on slide content, including number of layers, types of content, etc.
  • Increased right click area for slides in the Slide List – options for the slide now appear if you right click anywhere on the shaded slide. Previously, you need to click on the thumbnail itself.
  • Improved highlighting when dragging additional layers into a slide. Highlights now indicate when you’re dropping into a slide vs. inserting a new slide.

Improved File Listing

  • New! Double-click any photo to add it to your show.
  • New! Customize thumbnail sizes
    • Added options and preferences for thumbnail size in File List.
    • You can now select from a variety of different thumbnail sizes
    • Create and use multiple custom sizes for thumbnails
  • Improved indicators for what’s used in your show
    • Checkmarks on thumbnails and icons show which files are already used
    • Added the Used in Show indicator for audio and video files in File List
    • Added to Details view in the File List a column that indicates which files are used in the show.
    • Added ability to sort by what’s used in your show already
  • Improved Details List
    • Improved column names in Details view of File List to make them more easily understandable
    • New Megapixel column lets you see the resolution of your photos in megapixels
    • Improved size column shows size in kilobytes instead of bytes

Improved Status Bar

  • New! Enhanced the Status Bar to information about the currently selected slides.
  • The Status Bar now displays the total time of the selected slides and the number of selected slides.
  • When only one slide is selected, additional information is displayed, including slide number, name, and layer count

Additional Improvements and Enhancements

  • Added option to set Random Transition Effects from Preferences
  • Added preference to disable warning dialogs when adding files to templates and the template size and selected file count don’t match.
  • Added preferences to turn off confirmations for copying and moving multiple files.
  • Added button to remove watermark image from show
  • Added icon for files associated with ProShow, appears in Windows for PSH, PPR and PXS files.
  • Added safe zone toggle to Show Settings tab of Show Options
  • Changed ‘Options’ and ‘Slide’ buttons on main toolbar to ‘Show Opt’ and ‘Slide Opt’, and repositioned a few buttons to make the functionality more obvious.
  • Changed default size meter setting from VCD to DVD on new install.
  • Enhanced video import process by reducing dependency on external codecs
  • Enhanced visibility of icon buttons in most dialogs when the cursor is over them. Buttons now properly overstate (light up) when you mouse over them.
  • Improved performance of checking files used in a show for changes, which can greatly improve general responsiveness of ProShow in some situations.
  • Improved the ‘remove’ option for slide sounds to make it more obvious what the feature does.
  • Increased limit for manually set fade times for audio tracks, from 10 seconds to 30 seconds.
  • Added ‘Remove’ button for music on menus

Audio Fixes

  • Fixed audio failure caused by muting show from a menu page
  • Fixed audio stuttering problem caused by playing multiple Presenter based shows at once
  • Fixed problem where slide sounds could incorrectly continue into other slides
  • Fixed problem where some Quicktime videos could have bad audio once imported
  • Fixed problem where soundtrack volume did not get saved properly when set to zero

Stability Fixes

  • Fixed stability problems caused by very large shows
  • Fixed stability problems caused by certain memory usage situations
  • Fixed crash caused by loading a project which contained missing content
  • Fixed crash condition caused by long MP3 files
  • Fixed crash condition in Customize Menu dialog caused by empty menu pages
  • Fixed crash issue caused by importing certain Quicktime videos
  • Fixed crash issue caused by importing video from Kodak Zi6 pocket camera
  • Fixed crash problem caused by dropping an image onto a solid color / gradient layer
  • Fixed crash problem when creating output that can occur when one or more slides contain exceptionally long captions.
  • Fixed rare crash problem caused by certain layer transitions
  • Fixed rare crash problem caused by dragging multiple images into a show
  • Fixed rare crash problem caused by masking layers
  • Fixed playback crash affecting some web based shows that are played back at 16:9, but contain 4:3 menus, video thumbnails, and no intro show.
  • Fixed rare crash condition caused by Slide Style names that begin or end with a space.

Interface Fixes

  • Fixed default button for Add / Remove Keyframe Time dialog. ‘Ok’ is now the default button – allows improved workflow of typing a value and pressing Enter to apply.
  • Fixed display of unselected captions within the Caption Motion tab of Slide Options
  • Fixed display problem affecting motion paths in keyframe previews
  • Fixed error message regarding ‘cannot display page’ seen when opening Help
  • Fixed incorrect label in Shows tab of output dialogs, which incorrectly referred to the filename as the location.
  • Fixed issue where using the Edit Fades and Timing dialog would not check the ‘Custom’ checkbox for slide sounds, causing the changes to appear as though they were not applied. Custom checkbox is now automatically checked for you when you use the Edit Fades and Timing dialog.
  • Fixed issue with opacity sliders not adjusting properly when using arrow buttons to step slider left or right.
  • Fixed play / pause icons in Slide Styles tab of Slide Options to indicate the action to be performed if they are clicked, rather than the current state.
  • Fixed problem in Show Options / Background where color picker wasn’t disabled properly for Colorize when colorization was turned off.
  • Fixed problem where Slide Options could open partially off screen
  • Fixed problem where Slide Options could update incorrectly after selecting a solid color or gradient layer from a layers list
  • Fixed problem where buttons could be displayed incorrectly
  • Fixed problem where caption fly-in / fly-out options were not properly disabled when working with matched captions.
  • Fixed problem where layer copy options could fail to become enabled
  • Fixed problem where long audio files would display their length incorrectly in Slide Options and Show Options.
  • Fixed problem where mask depth field could become inaccessible after using Undo
  • Fixed problem where screensaver output dialog contained options for setting show titles and thumbnails, which don’t apply for screensavers.
  • Fixed problem where the soundtrack list in Show Options could incorrectly appear empty in some situations.
  • Fixed problem where using arrow keys to nudge a layer in the Slide Options preview would move the layer, but changes would not be immediately reflected in the related text fields for pan.
  • Fixed problem where zoom lock icon could incorrectly get focus, causing right-clicking to behave incorrectly.
  • Fixed problem with reset buttons for Character and Line Spacing options not resetting to the correct values.
  • Fixed problems that could cause slight errors in motion path display
  • Fixed problems with some caption control buttons
  • Fixed several layout problems in Precision Preview dialog which caused control buttons for adding / removing objects to be missing.
  • Fixed several sliders in Slide and Show Options to behave correctly when clicking on the left / right arrows (stepping) or in the scrollbar itself (paging).
  • Fixed typo in tooltip for zoom lock in Precision Preview
  • Updated description of Include Original Files feature more accurately describe the functionality of the feature.

General Usage Fixes

  • Fixed layer linkage problem that could affect non-replaceable layers
  • Fixed problem that could prevent Customize Menu to open for older projects
  • Fixed problem where “Add to Selected Slides” option would fail to mark a photo as ‘Used in Show’
  • Fixed problem where Collect Show Files would list total size of show content incorrectly.
  • Fixed problem where Configure Image Editor dialog could fall behind the main window, causing ProShow to appear locked up.
  • Fixed problem where MediaSource references could get lost after uninstalling ProShow
  • Fixed problem where adding captions keyframes using the ‘Add keyframe’ button would always add between keyframes 1 and 2, regardless of the selection. New keyframes are now properly added in between the selected keyframes.
  • Fixed problem where auto-rotated layers could not be cropped properly using the Crop tool under Editing.
  • Fixed problem where duplicated layers could end prematurely
  • Fixed problem where entering certain single-digit sizes in the caption size combo box would incorrectly select the wrong size.
  • Fixed problem where existing captions could not be edited in Precision Preview
  • Fixed problem where image field for show backgrounds could become blank
  • Fixed problem where layer outline size was not saved with menus
  • Fixed problem where layers could not be dragged by their center point
  • Fixed problem where reset button for Customize Menu / Thumbnail zoom would reset to 100% instead of 50%. Reset now sets the value to 50%.
  • Fixed problem where slide style names could not include certain legal characters
  • Fixed problem where slide styles could report the wrong aspect ratio if created from a show in a project
  • Fixed problem where some imported videos could appear with an incorrect aspect ratio
  • Fixed problem with Compatibility option when saving a slide style not correctly making the style Gold compatible when blur is used.
  • Fixed problem with slide style names that could prevent those styles from being edited or applied
  • Fixed problems that could cause File List to update improperly
  • Fixed problems where caption styles could include incorrect parameters
  • Fixed problems where macro based captions could fail to update as slide positions changed
  • Fixed problems with MPEG2 video layers caused by malfunctioning codecs
  • Fixed problems with linked layers and replaceable image slots
  • Fixed problems with rotation based caption motion
  • Fixed quality issue in MPEG4 videos created with Video File output
  • Fixed the Gold and Smoke caption styles

Playback Fixes

  • Fixed playback problems caused by looping animated GIFs that were cropped
  • Fixed problem where layers could appear incorrectly at very low Zoom values
  • Fixed problem where layers with a zoom value of zero could still be seen
  • Fixed problem where layers with very low zoom values (0-1%) could appear to momentarily ‘pop’ to 100% zoom during playback.
  • Fixed problem where preview would appear blank in trial installations if playback was started from certain parts of a show
  • Fixed problem where preview in Slide Options could loop in certain situations (instead of playing once and stopping)
  • Fixed problem where slide background could incorrectly disappear during playback.

Output Fixes

  • Fixed issue where YouTube uploads could function properly but appear to fail
  • Fixed problem where audio on Blu-ray menu could loop incorrectly
  • Fixed problem where layers could appear incorrectly when High Quality encoding is used to create video output.
  • Removed the 720i option for HD video output, as it is an unsupported standard

Additional Fixes and Changes

  • Added support for YouTube’s 1080p HD video uploading.
  • Fixed problem where some MP3 tracks could fail to play and appear with a flat waveform
  • Fixed problem where video layer could appear transparent at some keyframes
  • Fixed problem where video layers could scrub poorly after being added to a slide
  • Fixed rare crash condition caused by dragging an image into a template slot
  • Fixed problem where video layers could fail to appear in slide list thumbnails
  • Fixed problems with clarity of some video layers
  • Fixed problem where very large images could fail to fully preview from File List
  • Fixed crash problem caused by rendering to certain formats from Device output
  • Fixed problem where certain Nvidia graphics drivers could cause image previews to become corrupt
  • Fixed problems with scaling of keyframe and motion objects in Precision Preview dialog
  • Fixed problem with display of trimmed video layers during drag through preview
  • Fixed problem where Facebook uploads could fail
  • Fixed problem where ‘used in show’ flags within File List could fail to update after opening a show
  • Fixed audio problems affecting some video layers
  • Fixed crash problem caused by flipped video layers
  • Fixed problems with quality of FLV and WMV output
  • Fixed crash condition caused by cancelling the file save process while in the process of outputting a show
  • Fixed crash problem caused by opening shows with certain caption modifiers
  • Fixed problem where preview playback could appear at the wrong aspect ratio
  • Fixed problem where incorrect error dialog could appear after changing slide style categories
  • Fixed problem where layers rotated in crop dialog could fail to be displayed
  • Fixed problem where deleting a layer did not properly undo layer matching
  • Fixed problem where video layer could play at wrong speed after being flipped
  • Fixed problem with Presenter plugin installation when installing on a computer which has never had a copy of Presenter installed before.
  • Fixed issue where Presenter plugin would not playback properly in Firefox and Chrome
  • Fixed rare crash problem that could occur with certain shows containing layer motion

Stay Connected

Twitter Facebook

© 2015 Photodex Corporation