Is Presenter Plug-in 64-bit compatible?

Presenter Plug-in

The Presenter Plug-in is only available as a 32-bit plugin. It will run fine on 64-bit computers, but it not available for the 64-bit versions of web browsers.

By default, Windows 7 will use the 32-bit edition of Internet Explorer, even if you are running the 64-bit version of Windows 7. If you choose to run the optional 64-bit version of Internet Explorer 8 or 9 (or any 64-bit web browser), the Presenter Plug-in will not work, and you will not be able to view shows online. This is not a problem with the plug-in, or a limitation of ProShow. This is a restriction of 64-bit versions of various web browsers. 64-bit versions of today’s web browsers can only use 64-bit plug-ins, and will not allow 32-bit plug-ins to run.

This affects all plug-ins, and is a significant limitation on the usability of these browsers. Even extremely common plug-ins like Adobe Flash will not function under 64-bit browsers.

The only work-around at the moment is to use the 32-bit version of the web browsers to view online shows.

Stay Connected

Twitter Facebook

© 2015 Photodex Corporation